xmlrpc.php issue solved

  1. For those with xmlrpc issues here is what finally worked for me.
    Download a fresh xmlrpc file
    then go into the file permissions and check the boxes for it to be executed. Hope this helps others.

  2. in saying that using the xmlrpc does not allow me to post or edit posts, I can edit pages fine. I am not having any issues with the other two blogs with the newer xmlrpc, but this one not is no good for editing or posting a post. Sorry to bear the bad news for this issue, I am still banging my head against a brick wall. I have updated my post accordingly.

    According to my pictures here, it is a plugin issue, but what I don't understand is what plugin as I have pretty much the same one on ALL 3.

    Wow fixed it good and proper now, replaced the xml rpc file from 2.5 release! crazy what's going on? Thanks for the idea. oh and with this I don't have to edit permissions just straight upload.

    Ok, all the other 2 are still using the original 2.8.1 xmlrpc file. hmm weird!

  3. Success. Replacing my xmlrpc.php from 2.8.1 with the one from 2.6.5 fixed the "T0" issue for me too.

    I compared responses from the 2.6.5 xmlrpc and the 2.8.1 xmlrpc on my blog using the WordPress::XMLRPC module in Perl. They're similar except for in many places (but not all places), the "date_created_gmt" field was different.

    In 2.6.5, the format of this field looks right (however, the data seems to be the current time, not truly the "data created". For example:

    dateCreated      => "20081002T07:30:51",
    date_created_gmt => "20090720T19:25:06",
    page_id          => 137,
    page_parent_id   => 0,
    page_title       => "Events",

    Whenever this "date_created_gmt" appears with the current date (and not a GMT translation of the "dateCreated", the "date_created_gmt" value returned from the 2.8.1 xmlrpc is different. For example:

    dateCreated      => "20081002T07:30:51",
    date_created_gmt => "-0001113TT0::0::00",
    page_id          => 137,
    page_parent_id   => 0,
    page_title       => "Events",

    Note the invalid timestamp value for "date_created_gmt". I wonder if this is what is causing the WordPress BlackBerry app to choke and return the "T0" error.

  4. Yes just posted my findings of the 134 release here also ...

  5. thanks zmalone,

    The "T0 error" occur when the xmlrpc response contains invalid timestamp value for "date_created_gmt" field.
    We have patched the app with a more intuitive error message, to assist with this error, and will be available on next beta release.
    Anyway the error is on server side, and occurs only on self hosted WordPress.
    We are looking for a solution, for those with this issue
    you could replace your xmlrpc.php file as reported by zmalone.

  6. I'm glad this fixes the T0 problem!

  7. I think it was my draft/unpublished pages & posts that triggered the appearance of the date_created_gmt bug in xmlrpc.php.

    Found this post by Joseph Scott to the wp-xmlprc list and the associated trac ticket which looks like it was resolved in 2.8.1, but perhaps it's not completely resolved or perhaps this is a separate issue?

  8. I'd be very curious to know why this is happening. Can you reproduce it on a fresh, brand new install with the default theme and no plugins activated?

    If we can reproduce the problem I'm happy to help track it down and figure out a fix.

  9. Taking a quick look at your patch, Joseph, and it looks like it is specifically addressing the date_created_gmt bug on posts. I have several unpublished draft pages in my blog where I see the issue in date_created_gmt. Perhaps this is the gap?

    Also, it still looks like draft posts are getting bad timestamps in date_created_gmt, even with your patched version of xmlrpc.

    In 2.6.5, I see a draft post like:

    dateCreated              => "20090629T18:03:18",
    date_created_gmt         => "20090720T19:25:09",
    post_status              => "draft",

    In 2.8.1, I see the same draft post like:

    dateCreated              => "20090629T18:03:18",
    date_created_gmt         => "-0001113TT0::0::00",
    post_status              => "draft",
  10. @josephscott I have done all you asked of me on your reply to my post here. However I think zmalone has hit it on the head, I think it is that file. Also just found out that either the xmlrpc.php file from the older WP release, I can not moderate comments/ping backs, may be it is because of the disqus commenting system being in the way or what? but yeah would be good to see this fixed good, as not sure what holes there are in the older xmlrpc file. Thanks in advance.

  11. @zmalone -
    You're right, the fix I made for draft posts for the date_created_gmt field should go in for draft pages as well. I've got a patch to xmlrpc.php that does this.

    @zocster -
    The older versions of the xmlrpc.php file don't have the comment management methods.

    I'll be putting together a ticket to get this into the next release of WordPress. In you want to test it out drop me a note via and I'll email you a copy of my xmlrpc.php.

  12. email sent thanks mate :)

Topic Closed

This topic has been closed to new replies.

About this Topic