Forums

What should this app do for me?

  1. Hi,

    I've added this app to my Torch, pointed it at my web site (not WordPress.com hosted) and logged in (I guess) using an Editor account. In the top left-hand corner I see a warning triangle with an exclamation mark in it next to the site name. When I press refresh I get "Error while loading blog". When I click on Pages it says "No pages found". When I click on Stats it asks for my WordPress.com username and password even though the site isn't hosted there. When I click on Dashboard it loads the site in the browser but I still need to log in (something I can do without the app). I can't find anything that this does for me. Am I missing something? What is it supposed to do?

    Thanks

  2. The red triangle with exclamation mark appears if the app has found errors when adding blog.
    Try to refresh the blog. You should get a detailed information about the issue.

    Stats: You should install and configure the Jetpack plugin (stats functionality previously provided by WordPress.com Stats plugin): http://wordpress.org/extend/plugins/jetpack/

  3. Thanks for the reply. Every time I refresh,all I get is a popup that states "Error while loading blog". Is there a separate log where the detailed information should appear or would you expect it to appear in the popup?

  4. I suggest you to test your site with the on-line tool here: http://www.eritreo.it

    If that doesn't help:
    - Open the 'App settings screen' and enable the 'extra debug' option.
    - Save the changes.
    - Reproduce the issue.
    - Wait till the error message.
    - Close the app.
    - Connect the device to your PC and get the the app log file located at /store/home/user/wordpress/log* (or at /SDCard/BlackBerry/wordpress/log*).
    - Send us the app log file to mobile at automattic.com

  5. By the way, I don't currently have Jetpack installed. To date I have tried to keep to plugins that (amongst other criteria) have a rating of 4.0 or higher. Also I have not been convinced the benefits or Jetpack outweigh all the other stuff I have no interest in. Do I need Jetpack to use this App, or only to look at the stats?

  6. Have tried http://www.eritreo.it and "Congratulation! Your site passed the first check."

    Will I have to disable Google Authenticator to go any further? Indeed, do I need to disable it for this App to work?

  7. Do a full check with eritreo.it, by inserting username/password and check what is the response of the tool.

    About Google Authenticator, I think you need to create and use an application password if you've installed 2steps auth on your blog.

  8. I used my Editor account (rather than my Administrator account) which is the one I am using with this App. The response was a tick against every test.

    I'll try the extra debug when I get home tonight.

  9. Apologies for the delay in replying. I am now using version 1.6.6 of the app and still get "Error while loading blog". Have emailed you the log as requested.

  10. Thanks for sending us the log file. I've identified the cause of the breakage and we will fix the issue in the next app update.

  11. Great, thanks. One other thing I noticed was that, when data wsa disabled over the air, I got a different error trying to connect over WiFi. Can't remember the full details but, once I can connect, I'll see if the problem persists. If it does, I'll raise another ticket. Looking forward to the update.

  12. The problem is on the category called "Calendar", that has a really high ID number. Check in the database if something is going wrong with that category. You can even remove that category in the dashboard if you're not using it.

  13. Where in the database will I find the information and do you know what the ID number was?

    Thanks

Topic Closed

This topic has been closed to new replies.


About this Topic

Tags

No tags yet.