Forums

Problem uploading a Picture

  1. JohannaMelendez
    Member
    Apr 6, 2011, 12:26 AM

    Hi!

    I just wanna know what can i do with my wordpress. I want to upload a photo for my blog but i cant.

    I picked the resizing option and save. I set the resize option to 300 x 225 and i take the pic with a blackberry 9780 with 5mpx camera.

    Then when i have a new post i took the picture with my cel and try to upload but i got an error:

    Server Error -32700
    parse error. not well formed

    What is that? What can i do?

    Please help me!!

  2. Unfortunately, there is a bug within the Torch firmware that causes issues when using the XML-RPC services to publish images.
    Are you using a self-hosted Blog or a WordPress.com blog?

    If self-hosted, please enable the AtomPub protocol on your blog:
    1. Go to your blog and log in (/wp-admin).
    2. In the sidebar, open Settings and then select Writing.
    3. Under Remote Publishing, check to make sure the AtomPub protocol is enabled. If it's not, please enable it.
    4. Click Save Changes at the bottom of the page.

    Then, start the mobile app again, and go to the Setting Page and select the AtomPub within the Media API box.

  3. JohannaMelendez
    Member
    Apr 7, 2011, 3:56 AM

    Hi!

    My blackberry isn´t a torch.. is a Bold 9780. Unfortunately i have a WordPress.com blog :(

    ¿What can i do? If there i can do.

    Thanks for your answer!

  4. Could you please try changing the Video API option?
    - Start the mobile app
    - Click the bb key and select Setup
    - Select the AtomPub option within the Video API box
    - save the changes

  5. JohannaMelendez
    Member
    Apr 12, 2011, 2:29 AM

    Thaaaanks so much!!

    Everything is okey now. I´m so happy. :D

  6. I am having the same problem, changed it to AtomPub, but now I get an other error:

    "AtomPub Error HTTP Error 404 - Not Found"

    Does anyone knows what goes wrong?

  7. @bhollenberg -- Could you please make sure that AtomPub services are enabled on your blog. Go to Admin -> Settings; Writing; Remote Publishing and check the AtomPub box.

  8. I checked it again and the settings are as you described.

  9. @bhollenberg -- are you using WordPress.com or self-hosted WordPress?
    If self-hosted, I suggest you to contact the webmaster of your site, or hosting provider help desk and finding out if the default setup blocks AtomPub.

  10. @daniloercoli It is a self-hosted WordPress site. I will check with the hostingprovider if they know a bit more regarding AtumPub.

    Note that @bhollenberg is making use of a BB Bold 9780, and myself using a BB Bold 9700. I have no problems posting new posts with my 9700 (running the older OS 5), but @bhollenberg seem to have these 404 errors with the 9780 (running the OS 6).
    Does this sound familiar?

  11. @bhollenberg @hakman -- you can even force the XML-RPC protocol. Open the setup Screen and check XML-RPC within the "Media API" box.

    note: Unfortunately, there is a bug within the latest firmwares that causes issues when using the XML-RPC services to publish images. So, we started to use the AtomPub services just for media publication and only for latest devices. Unfortunately the AtomPub layer is not so tested on WordPress and the upload could fail if the server side is not configured. You should debug your blog installation activating the debug option within the file wp-app.php, and take a look at the log file to know what happens when a media file is uploaded to your blog.

  12. @daniloercoli, I'm not quite sure I understand where exactly to force the XML-RPC protocol. I did set the checks on the Wordpress Admin -> Settings -> Writing page for both the Atom Publishing Protocol and the XML-RPC.
    I couldn't find any other place to check the XML-RPC in the WordPress Admin page.
    I've also checked the BB Wordpress App, but the same there: no such checkbox that I could find.

    Could you please confirm that this is what you were talking about, or is there some place else I should look?

    Thanks!

  13. @hakman - you should force the XML-RPC protocol within the mobile app.
    - Start the app
    - hit the BB menu key and select the "Settings" menu item
    - check the XML-RPC protocol within the "Media API" box

Topic Closed

This topic has been closed to new replies.


About this Topic