Norwegian Characters don't work

  1. This is driving me crazy.

    I run wp 2.8.1, and no matter what I try, I can't post correctly with norwegian characters ( æ ø å). When I make a post, it is ok up until the first of these characters, then i cuts the rest of the post.
    I have tried reinstalling wordpress, and making sure both the wp-installation and the database is using UTF8. I tried changing it to latin1, and the then the post wasn't cut, but all the norwegian characters were replaced by questionmarks.
    I have tried everything I can think of both in the wordpress files and config, and in myphp-admin.

    Please help..

  2. A little additional info: The posts seem ok in the app, until I refresh them, and then everything after the first æ ø or å is gone, including the æ ø å itself. And in the blog, I see the cut post too.

  3. I have done a test on an self hosted WordPress (UTF-8) , and on a blog. All character are included in the post, also æ ø å.
    I can edit the post in WordPress for BlackBerry and I can post the changes without errors to the blog.

    did you try with an blog?

  4. I couldn't get it to work, so I ended up reinstalling Wordpress several times, and finally managed to fix it, by removing the lines in wp-config.php that deal with charset and collation, so that it defaults to latin_swedish_ci. Then, I set the option under "reading" in WP to latin_swedish_ci too, and now I am able to post using æ, ø, å.

    However, I can not edit the posts, as the app can't read latin_swedish_ci properly, so all my æøå's disappear when I view the posts in the app.

    So, it seems I'm halfway there....

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.