Could not find the xmlrpc endpoint...

  1. Just downloaded and installed the app. When I went to add my blog, I get the following error:

    We could not find the xmlrpc endpoint of your blog, please insert the complete url below.

    I enter the full path to the xmlrpc.php file ( and I still get the error. I have confirmed through seetings\writing that xmlrpc is enabled.

    * Site URL
    * Using self-hosted WordPress
    * If self-hosted, the version of WordPress you're using 2.8
    * The version of your BlackBerry OS 4.5
    * The exact model of BlackBerry device you are using BlackBerry Pearl 8100
    * Connection type -- wifi, edge, 3G, etc edge
    * The version of WordPress for BlackBerry you're using

  2. I was having the same issue, although I think I have a lead on the problem.

    I previously didn't have xml-rpc enabled for my blog, but did so in order to try out this app the other day. After downloading tonight's build, I tried manually entering the path to the xmlrpc.php file, but it wouldn't connect and kept prompting me to enter the URL.

    I tried navigating to the file with my web browser, and received a 406 error with the message "Not Acceptable
    An appropriate representation of the requested resource /xmlrpc.php could not be found on this server." That seemed weird! So I Googled this issue and came across a few solutions ... it apparently often has something to do with server security.

    What I eventually tried was adding
    <files xmlrpc.php>
    secfilterengine off
    into my .htaccess file.

    Now when I navigate to the file in my browser, I get the message "XML-RPC server accepts POST requests only." That seems better, I suppose.

    So now with those changes, I started the "add blog" steps yet again. This time I wasn't prompted for the xmlrpc.php URL! And my blog seems to have been successfully added to the app.

    I don't fully understand the security settings and what I did, but it has worked. :)

  3. Thanks. I also get 'XML-RPC server accepts POST requests only.' when I navigate to it using my browser as well, but I still get prompted for the path to it by WordPress for BlackBerry.

    Any other suggestions?

  4. Same deal here. Navigating to the xmlrpc.php page from a browser works fine, but can't add the blog to the BB client, even when specifying the full path.

    Verizon Blackberry Curve 8330, running, on EVDO network. WP4BB WP 2.8.1, self-hosted @

  5. @RobAtSGH
    I've done a little test on your xmlrpc endpoint. And seems that cannot accept xmlrpc request from app.

    HTTP/1.1 412 Precondition Failed
    Date: Fri, 10 Jul 2009 16:52:35 GMT
    Server: Apache
    Connection: close
    Content-Type: text/html; charset=iso-8859-1

  6. @daniloercoli

    Did you get similar results on mine?

  7. @Whealer
    your xmlrpc endpoint print out BOM character before of xml preamble.your xmlrpc endpoint print out BOM character before of xml preamble. And the content-lenght in the http response header, mismatch from the real response length. we are investigating if it could be consider as an app mistake.
    Meanwhile you could change your server settings and avoid it.

  8. @daniloercoli

    OK... Thanks! How would I go about changing that?

  9. id love to know how to change the settings as well.... same issue here.

  10. Probably you have modified your wp-config with an editor that has written BOM byte into php files.
    (modified php files should be saved in utf8 WITHOUT BOM).
    Have a look at WordPress support forum, there are different topics around this problem.

  11. Just to note that when viewing your XML-RPC URL with a browser it's correct to get the 'XML-RPC server accepts POST requests only.' message back as a response.

  12. OK... I could not figure out where the BOM character was, so I downloaded a fresh copy of xmlrpc.php from and I am still getting the same error. A file compare between the version I have and the new one I downloaded showed no deltas between the two.

    I am not a php programmer, so apologies for not understanding what may be going on here.

  13. Probably you have modified wp-config,php with an editor that has written BOM byte at the begin of that file.
    Open that file with an open source editor such as could find the detailed istructions to clean up the files on support forum. just search the word "bom" or "bom wordpress".

  14. Upon adding blog it says it cant locate the xmlrpc file, and after typing out the location it says "Blog Response Error"

    I've tried a fresh xmlrpc.php as well as deactivating all plugins. Anyone else made any progress on this issue?

  15. did you have typed url address without www at the beginning? (maybe url like

    what is the url of your blog?

Topic Closed

This topic has been closed to new replies.

About this Topic