Forums

Connection Error.

  1. When I try to set up a blog after entering all the required details to connect, I get this message, about 3 or 4 times:

    The application WordPress has attempted to open a connection to a location inside the firewall and outside the firewall which is not allowed by your IT policy.

    and after hitting ok everytime it pops up, I get this:

    A server communications error occured: No route to blog (that is exactly how it is spelt).

    I am trying to connect to my wordpress.com blog although I have a self hosted blog also but I want to test the app on my other blog first.

    BB curve 8900 version 4.6.1.114

  2. seeker34 -- have you looked at your connection settings ? Click "Setup" when in the WordPress app - and see what's selected and try tweaking that.

  3. I have checked the Enable Personal Setting option, but I still get the error message about the connection to inside and outside the firewall, and then it gives me this different error message after failing to connection

    An error occured : Permission denied

  4. This issue is related to your IT policy setting.

    Make sure that permissions are set correctly. On your BlackBerry, go to “Options > Advanced Options > Applications”. Scroll through the list and highlight and select “WordPress for BlackBerry”. Next, Click on the app, and choose Edit Permissions and ensure they are set to “Allow”.
    If you receive same error again, you can try to do the following:
    go to Options-> Security options-> Firewall-> Edit default permissions-> expand all options and make them all as Allow.
    Then go to Options-> Security options-> General setting-> IT policy name-> press the trackball and select Verify Security software.

    If that doesn't help:
    - If you are on BES connection, you can contact your IT department and ask them to allow Split Pipe policy
    - otherwise , start a search on internet with "the application has attempted to open a connection to a location inside the firewall and outside the firewall which is not allowed by your IT policy." There are different solution that could help you to fix your IT policy.

  5. I am experiencing this error as well. I have tried all the steps highlighted above.

    I am on the Rogers network and have tried the following APN settings

    1) APN: internet.com
    username and password blank

    2) APN: internet.com
    username and password guest

    I have installed the newest version, 0.9.0.149 and am using a Curve with OS 4.5

    Any ideas?

  6. @big4bound -- search the words "the application has attempted to open a connection to a location inside the firewall and outside the firewall which is not allowed by your IT policy" on internet. There are different solution that could help you to fix your IT policy.

  7. Why is a split-pipe required by the app? It's really bad IT policy and RIM advises against it. It's even disabled in their blank security policies. Can't the app work without it (the wordpress web interface, scribefire, and others work fine from within the firewall)?

  8. @jgmp -- Most probably your device contains an IT policy file that doesn't permit the slitted pipe.
    (you should change the IT policies, removing the splitted-pipe, not the firewall).

    Slitted pipe is a security tip used in Enterprise solutions (BES) - If your device makes a network call via Java application such as WordPress for BlackBerry, it stores an internal flag indicating that it has made a network call with the mode that it is set in. If modes are switched and the network call is made again you will receive the above error message. To resolve this as non enterprise user you will need to reset your handheld code/operating system. As Enterprise user your BlackBerry network administrator will need to set the IT Policies for your device. For a more detail explanation please visit the BlackBerry Knowledge Base.

Topic Closed

This topic has been closed to new replies.


About this Topic

Tags

No tags yet.