Forums

CANNOT UPLOAD NEW POSTS, system says "A Server Communication Error Occurred"

  1. Good day, everyone.

    Please can anyone at the technical support desk do me a massive favor by helping to sort out whatever problem has caused my WordPress for BlackBerry 1.5 to consistently return a message which says "A Server Communication Error Occurred" since April 10th?

    My blog address is:

    http://beegeagle.wordpress.com/

    I run a WordPress.com blog(NOT self-hosted) on a BlackBerry 5.0 OS. I use a BlackBerry Curve 8520. My connection type is EDGE and I use the WordPress for BlackBerry 1.5 software application.

    Being a highly mobile blogger, ninety five percent of my blog posts are logged in using WordPress for BlackBerry. Perhaps I need to add that my blog is a rather thriving one, having notched up 285,000 page views since October 2011 - nearly 65,000 hits last month(March) and a daily average of 2,300+ hits.

    Please, I really need to have this problem sorted out urgently. My blog followers need to be served, are asking to know what has gone awry and I cannot meet their needs at this time, to my utmost discomfiture. I have tried everything, including changing my settings to "ALLOW" in the master control panel and have even reinstalled the application altogether. Nothing seems to be working.

    Again, the PROBLEM

    Blog address:

    http://beegeagle.wordpress.com/

    PROBLEM
    (ERROR MESSAGE) says

    "A server communication error occurred"

    Summary

    My WordPress for BB won't now upload posts, it was working fine until April 10th using the manufacturer-defined default settings

    When I highlighted the "Advanced Options" in the "Setup" section of the application, I got an additional message attached which said:

    "TCP Conn: DNS error
    BIS Conn: Null"

    Obviously, I need...HELP !!

  2. We're looking into this problem and will post updates as we have more information on this.

  3. The app tried to connect to your blog using a secure connection (https) but apparently WordPress.com has stopped working on some BlackBerry due to a SSL issue.

    We're still looking into this problem, but I found a workaround
    You can add your blog within the app following the steps below:
    - Start the app
    - Remove the blog within the app by selecting the delete menu item. (note that phone drafts will be deleted!)
    - Tap the add blogs button
    - Select the last option (self hosted blog)
    - Insert this URLhttp://beegeagle.wordpress.com/xmlrpc.php
    - Insert your credentials

    Did you upgrade the device OS lately? Could you please post here the platform version and the OS version?

  4. Thanks for the expedited response, Dan.

    My OS and Platform

    v5.0.0.592
    Platform 5.2.0.58

    Moving on, I followed your instructions PRECISELY

    I added this

    http://http://XXXXXX.wordpress.com/xmlrpc.php

    and got this response

    "We could not find the XMLRPC endpoint of your blog".

  5. You need to use the following URL: http://beegeagle.wordpress.com/xmlrpc.php (only one http:// at the beginning of the URL)

  6. The funny thing is that the blog still automatically refreshes itself to show new comments. I am able to approve them as well. However, I CANNOT post a new thread, let alone post photos which for me and my teeming blog followers, is critical to putting solid flesh on the bones.

    Please, my stories feel so strange now. No photo added in 48 hours. I am counting on you to do something special to restore my blog operations to normalcy. WP for BB is the only mobile interface available to me since I can only log in a post via my Nokia device but cannot upload photos.

  7. Dan, I saw your last set of instructions pertaining to the self-hosting option

    After setting up the blog, I tried to add a photo to a published blog post and got the following response

    "An Error Occurred. SERVER RETURNED http CODE 502"

  8. OK, I switched onto a WiFi network a shot while ago and everything worked perfectly. Switching back to EDGE connectivity, the problem of error messages began to happen again.
    ,

  9. BY GOD, I RESOLVED IT !!

    God has DONE His Thing for me. All is OK again. I am only a bit disturbed by the fact that WordPress left me incommunicado for 24 hours.

    Truthfully, blogging has been meaningless to me since Tuesday because I had to forego so stories which I felt could not be posted without photos. So we have had a slow week, averaging 2,150 hits as against 2,500+ hits. I have not really been in my elements and that is why we hae scarcely posted any comments or ripostes either.

    When I noticed that I could post stories but not photos and that with WIFI everything worked as it should, I was challenged to try harder by researching the topic online. Seeing that some had pulled through by trying some ordinary things, I opted to go to the ADVANCED OPTIONS section and I took a deep breath. Since it was clear to me that a cookie was possibly getting in the way, I decided to clear out the phone's memory.

    By Jove, it WORKED.

  10. I am having the EXACT problem as stated by beeneagle above... Same error messages, same OS (which I have not updated lately), same BlackBerry, using Edge, etc. etc. My problem even started about the same day as noted above. I have checked all connections, permissions and everything looks as it should. I followed the advice (aka, workaround to the ssl issue) and deleted my app and added it back as self-hosting and still getting "server communication error occurred". My blog address is susanpcv.wordpress.com. Please help. (P.s. I have not tried deleting my phone's memory ... Yet)

  11. I am also having this problem. I've tried the solutions above, besides clearing out my phone's memory (I couldn't do it with the instructions above)...and I have no access to wireless so I can't switch that out. I know several friends who are struggling with this as well-Please help! We are desperate to be blogging again!!

  12. We're still looking into this problem. I'll be sure to update this thread as soon as I have any more information.
    Sorry for the trouble and thanks for your patience.

    @susanpcv - that's odd. Could you please follow the steps below? You should be able to add your blog by using HTTP connection (obviously, communication between your blog and the app will not be encrypted).

    - Start the app
    - Remove the blog within the app by selecting the delete menu item. (note that phone drafts will be deleted!)
    - Tap the add blogs button
    - Select the last option (self hosted blog)
    - Insert this URL http://susanpcv.wordpress.com/xmlrpc.php (only one http:// at the beginning)
    - Insert your credentials and tap 'Sign In'

  13. @jenpcv - Clearing out the phone's memory should not fix this issue. I did the 'memory wipe' many times on a test device, but the issue is still there. Try to add your blog as a 'self-hosted' blog by following the instructions above.

  14. I tried adding it as a self-hosting blog about a week ago, when the problem first occurred. Then I tried various things, including checking permissions and uninstalling/reinstalling the app. To no avail, I am still unable to post.

  15. Actually, I was not even able to add the blog. It would not work, using the exact instructions above, and my blog address, obviously.

  16. @jenpcv - Take a look at your connection settings:
    1. Click "Setup" when in the WordPress app
    2a. If you are an individual user (no BES user), Select Direct WiFi, direct TCP, WAP2 and BIS connection types only (do not select "enable advanced connection settings").
    2b. If you are an enterprise user, keep selected WiFi and BES.
    3. Add your blog by using URL http://susanpcv.wordpress.com/xmlrpc.php

  17. I followed the instructions, and was able to add the blog as a self-hosted one. I went to post, and received this response: An error occurred. Server returned HTTP response code 502". So I am still unable to upload new posts.

  18. I followed the instructions for a second time (deleting and re-adding as self hosting) and this time IT WORKED!!! Can't say that I did anything differently than when I tried a week ago, although I maybe had only BIS checked earlier (since I knew wifi, tcp and wan were not possibilities). Good luck Jen!

  19. I am still unable to upload posts with photos. Text posts upload perfectly fine, but I cannot upload posts with photos. I am still getting the "Server return http response code 502". Is there anything I can do to remedy this? Because bashing my head against the wall is not helping much, and I suspect throwing my phone into the watering hole won't either.

  20. @jenpcv - What is the URL of your blog?

  21. @jenpcv - The only known workaround is to add your blog as self-hosted site:

    - Start the app
    - Remove the blog within the app by selecting the delete menu item. (Phone drafts will be deleted!)
    - Tap the add blogs button
    - Select the last option (self hosted blog)
    - Insert this URL http://jenpcvsouthafrica.wordpress.com/xmlrpc.php (only one http:// at the beginning)
    - Insert your credentials and tap 'Sign In'

    Take also a look at your connection settings:
    1. Click "Setup" when in the WordPress app
    2a. If you are an individual user (no BES user), Select Direct WiFi, direct TCP, WAP2 and BIS connection types only. (do not select "enable advanced connection settings").
    2b. If you are an enterprise user, keep selected WiFi and BES.

  22. Sigh...I've done that all before. It worked once, then started giving me 502 errors for any posts with photos. I guess I'll try it again. Third time's a charm, right?

  23. Nope, no luck. Third try yielded no changes, and as the definition of insanity is trying the same thing time and time again, but expecting different results....perhaps I won't try this again. ;)

  24. This problem seems to have something to do with Resizing Dimension for images.

    The facts were that I could post to wordpress without any images attached to the post. But not make a post with images.

    Poss. Solution:

    Try making a test post with images, with the images set to size: small. Then make another test post with the images in Original size.

    After this, the app worked fine.

    It worked for me, but no idea why!

    (I did change the blog to 'self hosted' - although this made no difference, and still got the server error message).

  25. PS: Just tried this on my 2nd wordpress blog, and you must first do the work around 'self hosted' blog setup... Then make a post using small size images. After this you should be able to post original sized images...

    Work around copied from above:

    @jenpcv - The only known workaround is to add your blog as self-hosted site:

    - Start the app
    - Remove the blog within the app by selecting the delete menu item. (Phone drafts will be deleted!)
    - Tap the add blogs button
    - Select the last option (self hosted blog)
    - Insert this URL http://jenpcvsouthafrica.wordpress.com/xmlrpc.php (only one http:// at the beginning)
    - Insert your credentials and tap 'Sign In'

Topic Closed

This topic has been closed to new replies.


About this Topic